modul script

Download Modul Script

Post on 21-Sep-2014

58 views

Category:

Documents

0 download

Embed Size (px)

TRANSCRIPT

Script

Divisi Training Departemen Teknik PT UFOAKSES SUKSES LUAR BIASA Jakarta

Fungsi scriptMemaintenance task beberapa router Mengeksekusi perintah konsol berdasarkan waktu atau event Menaikkan kecepatan task pada sebuah router Script terdiri dari perintah konfigurasi dan expresi ( ICE = internal console expression )

Bagaimana menulis scriptMengunakan /system/script menu

Contoh : /system script add name=test source = {:log infoheloo world ! }

Menulis langsung dikonsol

Contoh : [admin@ufoakses]>:log infoheloo world!

Sintaks perintah consolePrefix = perintah expression seperti pada root level

[admin@MikroTik] > ip dns /ping 192.168.3.1 [admin@MikroTik] /log> .. [admin@MikroTik] /ip firewall mangle> .. [admin@MikroTik] /ip firewall>

Path = Relative path ke menu level

Path_args Action

Seperti add action =ip firewall filter add chain=forward /interface wireless set wlan1 ssid=nico

Name[=value]

Contoh perintah console/ping 10.0.0.1 count=6

Prefix= / Action=ping Unamed parameter= 10.0.0.1 Name[=value]= count=6

.. Ip firewall rule input

Path= ..ip firewall rule Path_args = input

:for I from=1 to=10 do {:put $i}

Prefix= : Action = for Unnamed parameter= I Pname[=value] = from=1 to=10 do {:put $i} Prfefix= / Path = interface Action = monitor-traffic Unnamed parameter = ether1,ether2,ether3,vlan

/interface monitor-traffic ether1,ether2,ether3,vlan

Berhitung dgn script[admin@MikroTik] > :put (1+2) 3 [admin@MikroTik] > :put (43-3) 40 [admin@MikroTik] > :put (43*3) 129 [admin@MikroTik] > : put (45+23+1) 69 [admin@MikroTik] > : put ( 10 / 2 ) 5

Perintah :[admin@MikroTik] > : environment do for len parse set toid tostr terminal error foreach local pick time toip totime beep execute global log put toarray toip6 typeof delay find if nothing resolve tobool tonum while

Menulis script via winbox

Bagaimana menjalankan scriptPerintah run

/system script run test

Menambahkan nama script pada tool task

/system scheduler add name=test on-event=test interval=10s

Dimana saja dari konsol

:put hai

Mengedit scriptMenggunakan perintah set

/system script set script_name source={}

Menggunakan editor

/system script edit script_name source

Full screen editor tidak jalan di single line mode

Monitoring scriptMengecek script counter dengan perintah print

/system script print

Melihat jalannya script

/system script job print

Variable dalam scriptMengunakan simbol $ Global= system wide

:global a ; :set a 5; :put $a :local e; :set e 11 :put $e :foreach s in 1,2,3 do={put $s} /interface eth1 monitor ether1 do={:put $status}

Local

Loop

Monitoring

Contoh penggunaan variable[admin@MikroTik] > :global g1 "nico mau belajar variabel" [admin@MikroTik] > :put $g1 nico mau belajar variabel [admin@MikroTik] > : global g2 "alooo" [admin@MikroTik] > :global g1 g2

Tipe dataList Internal number Number IP address Time Boolen string

Konversi tipe dataFungsi untuk konversi data adalah

toarray tobool toid toip tonum tostr totime

Perintah Get dan findGet [admin@MikroTik] > :put [/ip address get 0 address ] 12.12.12.5/24 Find [admin@MikroTik] > /interface enable [find type=ether]

Contoh tipe dataHexadesimal [admin@MikroTik] > :global var 0x10 [admin@MikroTik] > :put $var 16 Waktu [admin@MikroTik] > :put 2d11h12 2d11:00:12 Waktu dengan deimal [admin@MikroTik] > :put 0.1d1.4s 0.1d1.4s

[admin@MikroTik] > : beep [admin@MikroTik] > : beep length=2s frequency=10000

Script EditorDigunakan untuk merubah script [admin@MikroTik] > sys scr add name=aku [admin@MikroTik] > sys scr pr Flags: I - invalid 0 name="tes" owner="admin" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff run-count=0 source=:log info " weleh-weleh " 1 name="nico" owner="admin" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff run-count=0 source=:put "heloo aku disini" 2 name="aku" owner="admin" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff run-count=0 [admin@MikroTik] > sys scr edit number: 2 value-name: source source=""

Script editor di winbox