Cara Setting Mikrotik Dengan ISP Speedy

Download Cara Setting Mikrotik Dengan ISP Speedy

Post on 22-Nov-2014

486 views

Category:

Documents

3 download

Embed Size (px)

TRANSCRIPT

<p>Cara Setting Mikrotik dengan ISP SpeedySkema Jaringan dan IP Address yang akan dibuat: SPEEDY (Internet) &gt; Modem ADSL (IP modem=192.168.1.1) &gt; (IP ether1=192.168.1.2) Mikrotik Routeros (IP ether2=10.0.0.30) &gt; LAN (IP LAN=10.0.0.1 s/d 10.0.0.29) IP Address LAN, kita gunakan network 10.0.0.0/27 (transfer data =27 bit untuk maks 30 IP Address/komputer). Untuk Mikrotik RouterOS, kita perlu dua ethernet card. Satu (ether1 - 192.168.1.2/24) untuk sambungan ke Modem ADSL dan satu lagi (ether2 - 10.0.0.30/27) untuk sambungan ke LAN/switch. Untuk Modem ADSL, IP kita set 192.168.1.1/24. Pastikan Anda sebelum mengetikkan apapun, telah berada pada root menu dengan mengetikkan / 1. Set IP untuk masing ethernet card: ip address add address=192.168.1.2/24 interface=ether1 ip address add address=10.0.0.30/27 interface=ether2 Untuk menampilkan hasil perintah di atas ketikkan perintah berikut: ip address print Kemudian lakukan testing dengan mencoba nge-ping ke gateway atau ke komputer yg ada pada LAN. Jika hasilnya sukses, maka konfigurasi IP Anda sudah benar ping 192.168.1.1 ping 10.0.0.30 2. Menambahkan Routing ip route add gateway=192.168.1.1 (IP Gateway adalag IP modem) 3. Setting DNS ip dns set primary-dns=203.130.193.74 allow-remote-requests=yes ip dns set secondary-dns=202.134.0.155 allow-remote-requests=yes Karena koneksi menggunakan Speedy dari Telkom, maka DNS yg kita gunakan DNS Telkom. Silahkan sesuaikan dengan DNS Telkom masing tempat Anda berada. Setelah itu coba Anda lakukan ping ke yahoo.com misalnya: ping yahoo.com Jika hasilnya sukses, maka settingan DNS sudah benar</p> <p>4. Source NAT (Network Address Translation) / Masquerading. Agar semua komputer yg ada di LAN bisa terhubung ke internet juga, maka Anda perlu menambahkan NAT (Masquerade) pada Mikrotik. ip firewall nat add chain=srcnat action=masquerade out-interface=ether1 Sekarang coba lakukan ping ke yahoo.com dari komputer yang ada di LAN ping yahoo.com Jika hasilnya sukses, maka setting masquerade sudah benar 5. DHCP (DynamicHost Configuration Protocol) Supaya praktis, kita gunakan saja DHCP Server. Agar setiap ada klien yang ingin konek, dia ga perlu setting IP secara manual. Tinggal obtain aja dari DHCP Server, beres dah. Untungnya Mikrotik ini juga ada fitur DHCP Servernya. Jadi ya ga ada masalah OK! Langkah2nya sbb: Buat IP Address Pool ip pool add name=dhcp-pool ranges=10.0.0.1-10.0.0.29 Menambahkan DHCP Network ip dhcp-server network add address=10.0.0.0/27 gateway=10.0.0.30 dnsserver=203.130.193.74,202.134.0.155 Menambahkan Server DHCP ip dhcp-server add name=DHCP_LAN disabled=no interface=ether2 address-pool=dhcppool Sekarang coba lakukan testing dari komputer klien, untuk me-request IP Address dari Server DHCP. Jika sukses, maka sekali lagi, settingannya sudah OK. 6. Bandwidth Control Agar semua komputer klien pada LAN tidak saling berebut bandwidth, maka perlu dilakukan yg namanya bandwidth management atau bandwidth control Model yg saya gunakan adalah queue trees. Untuk lebih jelas apa itu, silahkan merujuk ke situsnya Mikrotik. (http://mikrotik.co.id) Kondisinya seperti ini: Koneksi Speedy sekarang ini katanya speednya sampai 1Mbps/128kbps (Download/Upload). Untuk itu setingan bandwidth management nya bisa kita set sbb berikut: Tandai semua paket yg asalnya dari LAN ip firewall mangle add src-address=10.0.0.0/27 action=mark-connection ip firewall mangle add connection-mark=Clients-con action=mark-packet new-packetmark=Clients chain=prerouting new-connection-mark=Clients-con chain=prerouting</p> <p>Menambahkan rule yg akan membatasi kecepatan download dan upload queue tree add name=Clients-Download parent=ether2 packet-mark=Clients limit-at=0 max-limit=0 queue tree add name=Clients-Upload parent=ether1 packet-mark=Clients limit-at=0 maxlimit=0 Nilai download dan upload kita set 0 (nol) dengan tujuan agar bandwidth yang kita dapatkan tidak terbatasi. Karena pada saat-saat tertentu speed speedy bisa mencapai 1,5Mbps. Jadi kalo kita set maks=1mbps maka speed yang kita dapatkan hanya mentok 1mbps saja. rugikan Sekarang coba lakukan test download dari beberapa klien, mestinya sekarang tiap2 klien akan berbagi bandwidthnya. Jika jumlah klien yg online tidak sampai 10, maka sisa bandwidth yang nganggur itu akan dibagikan kepada klien yg online. 7. Graphing Mikrotik ini juga dilengkapi dengan fungsi monitoring traffic layaknya MRTG biasa. Jadi kita bisa melihat berapa banyak paket yg dilewatkan pada PC Mikrotik kita. tool graphing set store-every=5min Berikutnya yang akan kita monitor adalah paket yg lewat semua interface yg ada di PC Mikrotik kita.tool graphing interface add-interface=all store-on-disk=yes Sekarang coba arahkan browser anda ke IP Router Mikrotik (IP ether2 yang ke LAN) http://10.0.0.30/graphs/ Nanti akan ada pilihan interface apa aja yg ada di router Anda. Coba klik salah satu, maka Anda akan bisa melihat grafik dari paket2 yg lewat pada interface tersebut. Sampai disini kita telah selesai melakukan setting mikrotik dasar untuk koneksi speedy.</p> <p>Tutorial Setting Mikrotik RouterOS PPPoE Client Sebagai Gateway Telkom SpeedyOleh jags 67 Komentar Kategori: Mikrotik dan Routing Sebetulnya saya sendiri masih kurang begitu menguasai mikrotik, disini saya mencoba untuk berbagi pengalaman aja. Semoga bermanfaat.</p> <p>Kita mulai setup dari modem adsl nya sebagai brigding protocol mode. Settingnya dapat anda temukan dari manual masing-masing modem. Contoh setting bridging protocol pada modem TECOM AR1031 pada menu Advance setup &gt; WAN. Ikuti petunjuk gambar dibawah ini kemudian lakukan save/reboot.</p> <p>Selesai setting modem sebagai bridging yang tidak menyimpan password dan user ID anda di modem, bagi anda yang ingin mencoba mengganti IP address default modem bisa di konfigurasi terlebih dahulu melalui PC client. Caranya : kita ubah terlebih dahulu IP modem pada Advance Setup &gt; LAN IP Address contoh 10.10.10.1 lakukan save/reboot. Kemudian lakukan pengubahan selanjutnya di IP client PC ke 10.10.10.2 selesai. Silahkan anda coba ketik di web browser anda IP modem (10.10.10.1). Berhasil? Kita lanjut ke CPU Mikrotik RouterOS nya. Tentukan IP Address masing-masing LAN card anda, misal LAN connector dari modem 10.10.10.2 (public), dan 192.168.1.1 ke jaringan lokal anda (lokal). Lakukan perintah ini terlebih dahulu jika anda ingin menspesifikasikan nama ethernet card anda. interface ethernet set ether1 name=public interface ethernet set ether2 name=lokal Pastikan kembali dalam menentukan nama dan alur kabel tersebut, kemudian kita lanjut ke setting IP Address. /ip address add address=10.10.10.2/24 interface=public /ip address add address=192.168.1.1/24 interface=lokal /ip address&gt; print Pastikan LAN card anda tidak dalam posisi disabled. Selanjutnya anda bisa memasukkan entry PPPoE Client. /interface pppoe-client add name=pppoe-user-mike user=mike password=123 interface=public service-name=internet disabled=no</p> <p>Sebetulnya perintah diatas dapat anda lakukan di winbox, jika ingin lebih mudah sambil cek koneksi jaringan anda ke mikrotik. Menentukan Gateway dan Routingnya dilanjutkan ke masquerading /ip route add gateway=125.168.125.1 (IP Gateway Telkom Speedy anda) /ip route print IP gateway diatas belum tentu sama, lihat terlebih dahulu ip pppoe client anda. Jika anda belum yakin 100% ip client anda dan gateway nya, lakukan login dan dialing melalui modem anda terlebih dahulu bukan pada mode bridging seperti diatas. Pada menu Device Info akan tampil informasi Default Gateway dan IP client pppoe anda. Ok? Selanjutnya masquerading, untuk penerusan perintah dari routing yang diteruskan ke nat firewall mikrotik untuk proses routing ke semua client yang terkoneksi /ip firewall nat add chain=srcnat action=masquerade Selesai.. tahap routing sudah terlaksanakan. Coba lakukan ping ke mikrotik dan gateway nya. Jika anda ingin sharing ke komputer client jangan lupa masukkan ip gateway pada settingan Network Connection (windows) sesuai dengan IP lokal pada mikrotik anda. Banyak sekali settingan mikrotik yang dapat anda pelajari dari berbagai sumber. Jika terkesan terlalu rumit dengan sistem pengetikan anda bisa melakukannya dengan winbox mode, setiap tutorial yang anda butuhkan pun dapat anda copy dan paste ke winbox nya mikrotik. Setting DNS dan Web Proxy Transparant Input DNS dan web-proxy pun terasa lebih mudah di winbox mode, masukkan primary, secondary dan allow remote request nya, atau dengan perintah di terminal winbox. /ip dns set primary-dns=203.130.206.250 /ip dns set primary-dns=202.134.2.5 /ip dns allow-remote-request=yes /ip web-proxy set enabled=yes port=8080 hostname=proxy.koe transpa rent-proxy=yes /ip firewall nat add in-interface=lokal dst-port=80 protocol=tcp action=redirect to-ports=8080 chain=dstnat dst-address=!192.168.1.1/24 Link-link firewall pada mikrotik http://www.mikrotik.com/testdocs/ros/2.9/ip/filter.php http://wiki.mikrotik.com/wiki/Firewall Semoga membantu.</p> <p>Jangan lupa untuk menset IP gateway client anda ke 192.168.1.1 agar terkoneksi ke server mikrotik anda dan tidak lupa saya ucapkan terima kasih untuk kadhol yang dahulu berkenan memberikan tutor step by step setup mikrotik router newbie buat saya.</p> <p>SETTING MICROTIKSETTING MICROTIK</p> <p>pilihlah paket paket dibawah ini untuk install OS Microtik :</p> <p>System, dhcp, Advance Tools, RouTing, Security, Web Proxy.</p> <p>ganti nama system sesuai dengan selera anda :</p> <p>[admin@microtik] &gt; system identity set name=warnet Selanjutnya promt shell akan berubah menjadi : Seperti yg anda inginkan : [admin@warnet] &gt;</p> <p>Ubahlah Password OS microtik anda dengan cara :</p> <p>[admin@warnet] &gt;user set admin password=</p> <p>aktivkan kedua Ethernet pada PC yang telah anda install OS Microtik :</p> <p>[admin@warnet] &gt;interface ethernet enable ether1 [admin@warnet] &gt;interface ethernet enable ether2</p> <p>Berikan nama pada kedua ethernet untuk memudahkan konfigurasi :</p> <p>[admin@warnet] &gt;interface Ethernet set ether1 name=modem ===== Ethernet yg utk modem [admin@warnet] &gt;interface ethernet set ether2 name=local === Ethernet yg untuk ke HUB</p> <p>Masukan IP pada kedua landcard :</p> <p>[admin@warnet] &gt;ip address add interface=modem address= ( Diisi IP address dari ISP ) / netmask [admin@warnet] &gt;ip address add interface=lokal address= 192.168.0.1/255.255.255.0</p> <p>masukkan IP gateway yg di berikan dari ISP :</p> <p>[admin@warnet] &gt; ip route add gateway=10.11.1.1560</p> <p>SETTING DNS :</p> <p>[admin@warnet] &gt;ip dns set primary-dns=10.11.155.1secondary-dns=10.11.155.2 setelah itu coba ping semua IP yang telah di setting di atas. [b][font=]KONFIGURASI FIREWALL DAN NETWORK ip firewall nat add action=masquerade chain=srcnat ip firewall filter add chain=input connection-state=invalid action=drop ip firewall filter add chain=input protocol=udp action=accept ip firewall filter add chain=input protocol=icmp action=accept [font=]/ip firewall filter add chain=input in-interface=(ethernet card yg ke lan) action=accept /ip firewall filter add chain=input in-interface=(ethernet card yg ke internet) action=accept ip firewall filter add chain=input action=drop ip web-proxy set enabled=yes src-address=0.0.0.0. port=8080 hostname= yahuu.net=yes parent-proxy=0.0.0.0:0 \ cache-administrator=webmaster max-object-size=4096KiB cache-drive=system max-cachesize=unlimited \ max-ram-cache-size=unlimited ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=3128 /ip firewall nat add in-interface=modem dst-port=80 protocol=tcp action=redirect to-ports=3128 chain=dstnat dst-address=!192.168.0.1/24 ================================================== ================ yang 3128 semuanya di ganti 8080 : caranya : ip web-proxy set enable=yes /ip web-proxy set port=3128 /ip web-proxy set max-cache-size=3145728 ( 3 kali total ram ) /ip web-proxy set hostname=proxy.prima /ip web-proxy set allow-remote-requests=yes /ip web-proxy set cache-administrator: primanet.slawi@yahoo.com ================================================== ================================================== ======== FILTERING : http://www.mikrotik.com/testdocs/ros/2.9/ip/filter.php/ ip firewall filter add chain=input connection-state=invalid action=drop \comment=Drop Invalid connections add chain=input connection-state=established action=accept \comment=Allow Established connections add chain=input protocol=udp action=accept \ comment=Allow UDP add chain=input protocol=icmp action=accept \ comment=Allow ICMP add chain=input src-address=192.168.0.0/24 action=accept \ comment=Allow access to router</p> <p>from known network add chain=input action=drop comment=Drop anything else ANTI VIRUS UTK MICROTIK : add chain=forward action=jump jump-target=virus comment=jump to the virus chain ++++++ ++++++++++++++++++++++++++++++++++++++++++++ +++++ add chain=forward protocol=icmp comment=allow pingadd chain=forward protocol=udp comment=allow udpadd chain=forward action=drop comment=drop everything else================================================== ===== SECURITY ROUTER MICROTIK ANDA : / ip firewall filteradd chain=input connection-state=established comment=Accept established connectionsadd chain=input connection-state=related comment=Accept related connectionsadd chain=input connection-state=invalid action=drop comment=Drop invalid connections add chain=input protocol=udp action=accept comment=UDP disabled=no add chain=input protocol=icmp limit=50/5s,2 comment=Allow limited pings add chain=input protocol=icmp action=drop comment=Drop excess pings add chain=input protocol=tcp dstport=22 comment=SSH for secure shelladd chain=input protocol=tcp dst-port=8291 comment=winbox # Edit these rules to reflect your actual IP addresses! # add chain=input srcaddress=159.148.172.192/28 comment=From Mikrotikls network add chain=input srcaddress=10.0.0.0/8 comment=From our private LAN# End of Edit #add chain=input action=log log-prefix=DROP INPUT comment=Log everything elseadd chain=input action=drop comment=Drop everything else http://wiki.mikrotik.com/wiki/Securing_your_router ================================================== ======================================== SETTING KEAMANAN JARINGAN HANYA UNTUK LOKAL AREA ANDA : /ip firewall filteradd chain=forward connection-state=established comment=allow established connections add chain=forward connection-state=related comment=allow related connectionsadd chain=forward connection-state=invalid action=drop comment=drop invalid connections add chain=virus protocol=tcp dst-port=135-139 action=drop comment=Drop Blaster Worm add chain=virus protocol=udp dst-port=135-139 action=drop comment=Drop Messenger Worm add chain=virus protocol=tcp dst-port=445 action=drop comment=Drop Blaster Worm add chain=virus protocol=udp dst-port=445 action=drop comment=Drop Blaster Worm add chain=virus protocol=tcp dst-port=593 action=drop comment=________ add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment=________ add chain=virus protocol=tcp dst-port=1080 action=drop comment=Drop MyDoom add chain=virus protocol=tcp dst-port=1214 action=drop comment=________ add chain=vir...</p>